aeontimeline

Open full view…

[Bug] Entity List

dlet
Tue, 01 Jan 2019 21:33:45 GMT

Hi Aeon Team, I've been struggling hours with this, and I think this is definitely a bug. 1) Create an entity type which is meant to be a list, and uncheck "Allow multiple per event" 2) When trying to sync with a Scrivener project, in Project Sync Settings, it is impossible to select a custom metadata which is a List. -> First bug. 3) When creating a New custom field, in Project Sync Settings, it works fine and does create a custom metadata in Scrivener. In this metadata is a list. But if you reopen the Project Sync Settings, then the field appears to be empty. -> Second bug. 4) If you have several List fields, they all have an invisible "null" value. If you try to edit another field, an error is displayed in red. -> Third bug Long story short : it seems impossible to have a single option List for a role and sync it with Scrivener, and be able to reedit the sync settings. Which is pretty annoying for my workflow. Mac OSX Mojave. Aeon 2. Scrivener 3. Tried to reboot. Tried to sync blank projects. Still no luck. Could you guys take a look and let me know if this a bug that only occurs on my computer? And if there's a workaround, please let me know. Thanks Note : here's a screenshot of the sync panel, where Person and Category are two List fields with a single option. [Screenshot](//muut.com/u/aeontimeline/s1/:aeontimeline:hQzl:capturedecran20190101a22.25.58.png.jpg)

aeonjess
Sun, 06 Jan 2019 05:52:06 GMT

Hi, Thanks for reporting this to us. We have been able to replicate the issue on our end, so we will look into fixing it and providing a fix in a future update. Unfortunately I'm not sure if there is a way around this at the moment, so we will try to get the fix out as soon as possible. We will let you know if we need anymore information from you. Jess

dlet
Sun, 06 Jan 2019 10:59:55 GMT

Hi Jess, Thanks for the update. Looking forward to the fix. And of course, let me know if I can assist further. Thanks,